x360Sync Issue

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 07:04 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2025 - 08:46 MDT

Identified

We have identified the root cause of the x360Sync issue and are now expediting a solution.
Posted Jun 19, 2025 - 07:47 MDT
This incident affected: x360Sync (x360Sync Web (US), x360Sync Data Transfer (US), x360Sync Collaborative Web Editing (US), x360Sync Web Preview (US)).