x360Portal Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Aug 19, 2024 - 07:34 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2024 - 06:49 MDT
Investigating
We are investigating an issue with Axcient x360Portal. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Aug 19, 2024 - 06:34 MDT
This incident affected: x360Portal (Support Ticketing, Axcient Marketing Portal, Axcient Invoicing and Payments, Training & eLearning, Authentication, Dashboard).