x360Cloud Microsoft API Performance Degradation in AMS
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 19:26 MDT
Monitoring
Performance has returned to normal for backups of almost all organizations in this region. Backup reports should return to normal over the next 24 hours. We continue to monitor the situation closely.
Posted Mar 27, 2023 - 17:20 MDT
Investigating
Communications with the Microsoft Graph API from the x360Cloud application in the AMS region have been experiencing slow performance over the weekend, which has caused backup performance for backups within this region to slow down substantially. We are seeing performance improve back towards normal levels and are monitoring closely. MSPs may see some organizations report with scans still in progress or unscanned due to this issue over the weekend.
Posted Mar 26, 2023 - 17:32 MDT
This incident affected: x360Cloud (Microsoft 365 Backup (EU), Google Workspace Backup (EU)).