x360Sync Issue
Incident Report for Axcient
Resolved
We have completed upgrades that have alleviated all network congestion partners may have been experiencing.
Posted Nov 12, 2024 - 22:54 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 12, 2024 - 12:12 MST
Investigating
We are investigating an issue with Axcient x360Sync causing reduced performance for certain clients. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Nov 12, 2024 - 12:12 MST
This incident affected: x360Sync (x360Sync Web (US), x360Sync Data Transfer (US)).