Axcient Anchor CA SaaS Issues
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 04:30 MST
Investigating
We are investigating an issue with Axcient Anchor CA SaaS. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Dec 18, 2019 - 03:21 MST
This incident affected: Anchor (Canada) (Anchor Web, Anchor Sync, Anchor Email Notification, Anchor Collaborative Web Editing, Anchor Web Preview, Anchor Private Cloud Collaborative Web Editing, Anchor Private Cloud Web Preview).