x360Cloud (formerly CloudFinder) Issue
Incident Report for Axcient
Resolved
The issue with Axcient x360Cloud is resolved. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted Apr 15, 2024 - 14:50 MDT
Monitoring
We implemented a solution to resolve the issue with x360Cloud. We are now monitoring the results.
Posted Apr 15, 2024 - 11:41 MDT
Investigating
We are currently investigating an issue with backup reports failing to generate properly. We have confirmed that x360Cloud backups are running normally and this issue is only with the generation of the backup reports themselves. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Apr 15, 2024 - 08:57 MDT
This incident affected: x360Cloud (x360Cloud Management Portal (US)).