x360Recover US Incident

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted 13 days ago. May 01, 2025 - 07:34 MDT

Identified

We are experiencing an issue with x360Recover backup and restores affecting a small number of partners. The issue has been identified and we are working to re-enable services as quickly as possible.
Posted 20 days ago. Apr 24, 2025 - 06:52 MDT
This incident affected: x360Recover (x360Recover Cloud (US)).