x360Recover Issue

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 17:45 MDT

Identified

We are experiencing an issue with the x360Recover Cloud affecting a small percentage of partners where backups and recovery will not be able to be performed. We are expecting this to be resolved by EOD.
Posted Apr 23, 2025 - 13:40 MDT
This incident affected: x360Recover (x360Recover Cloud (US)).