x360Sync Issue

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 14:57 MDT

Investigating

We are investigating an issue with Axcient x360Sync. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Mar 11, 2025 - 14:40 MDT
This incident affected: x360Sync (x360Sync Web (US)).