x360Sync Issue

Incident Report for Axcient

Resolved

This issue has been resolved as of approximately 16:00 UTC today.
Posted Jun 18, 2025 - 13:18 MDT

Identified

We are continuing to experience a DoS against our US x360Sync client connection services. We are working to isolate this issue as quickly as possible.
Posted Jun 18, 2025 - 08:10 MDT

Investigating

We are investigating an issue with Axcient x360Sync. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Jun 18, 2025 - 07:27 MDT
This incident affected: x360Sync (x360Sync Web (US), x360Sync Data Transfer (US), x360Sync Collaborative Web Editing (US), x360Sync Web Preview (US)).