x360Recover (formerly Replibit) Issue

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Mar 28, 2023 - 14:09 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2023 - 08:25 MDT

Investigating

We are investigating an issue with Axcient x360Recover (formerly Replibit). We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Mar 28, 2023 - 07:42 MDT
This incident affected: x360Recover (x360Recover Cloud (EU)).