Services unavailable in Canada
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 17:32 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2024 - 14:16 MDT
Investigating
We are currently investigating an incident that is impacting Axcient services in our Canada region.
Posted Oct 21, 2024 - 13:14 MDT
This incident affected: x360Recover (x360Recover Cloud (CA)), Business Recovery Cloud (BRC) (BRC Offsite Replication (CA), BRC Cloud Virtual Office (CA)), x360Sync (x360Sync Web (CA), x360Sync Data Transfer (CA), x360Sync Collaborative Web Editing (CA), x360Sync Web Preview (CA)), and x360Recover Manager (x360Recover Virtual Office (CA)).