x360Portal Issue
Incident Report for Axcient
Resolved
Access to our billing services from x360Portal has been restored.
Posted Nov 13, 2024 - 15:07 MST
Identified
We are experiencing an issue with our billing provider that is preventing partners from accessing their billing and payments within x360Portal.
Posted Nov 13, 2024 - 10:10 MST
This incident affected: x360Portal (Axcient Invoicing and Payments).