x360Recover (formerly Replibit) Issue

Incident Report for Axcient

Resolved

The issue with Axcient x360Recover is resolved. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted Nov 28, 2023 - 14:40 MST

Monitoring

We implemented a solution to resolve the issue with x360Recover. We are now monitoring the results.
Posted Nov 28, 2023 - 12:57 MST

Investigating

We are investigating an issue with Axcient x360Recover (formerly Replibit) with Virtual office. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Nov 28, 2023 - 10:57 MST
This incident affected: x360Recover Manager (x360Recover Virtual Office (US), x360Recover Virtual Office (EU)).