x360Recover US Appliance Connectivity

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 06:22 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2025 - 15:02 MDT

Identified

We are continuing to investigate the issue affecting tunnels for x360Recover in the US affecting some partners.
We are also aware that this may be impacting connectivity for x360Sync agents.
Posted Jun 16, 2025 - 13:07 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2025 - 11:56 MDT

Investigating

We are investigating an issue with Axcient x360Recover connectivity in the US. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Jun 16, 2025 - 08:46 MDT
This incident affected: x360Sync (x360Sync Data Transfer (US)) and x360Recover Manager (x360Recover Tunnel Services, BRC Cloud Tunnel Services).