x360Cloud Issue

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 08:04 MST

Monitoring

A fix has been implemented and we are monitoring results. It will take a few more hours to generate new backup reports.
Posted Jan 13, 2026 - 03:31 MST

Identified

We have identified an issue with Microsoft 365 mail backups in the EU environment. This issue affects only backups for Microsoft 365 mail data and results in a "Partial" backup status for impacted organizations. We are working to resolve the issue and apologize for any inconvenience this may cause.
Posted Jan 12, 2026 - 03:26 MST
This incident affected: x360Cloud (Microsoft 365 Backup (EU)).