x360Cloud (formerly CloudFinder) backup service performance is currently degraded.
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Mar 28, 2023 - 20:51 MDT
Monitoring
Multiple enhancements have been released that have resolved the issues with random users not being scanned for 24-hour durations, and certain organizations reporting in a not-fully-scanned state. We are closely monitoring SLA levels to ensure that all issues have been resolved.
Posted Mar 24, 2023 - 10:15 MDT
Update
The main cause of backups failing for long periods of time has been resolved. However, each day less than 0.5% of users (random across the base) may experience a random delay or lack of backup for a single 24 hour period. MSPs may see reports of organizations in a not-fully-scanned state. No action is required and backups for any such affected users should automatically become healthy again within 24 hours. Engineering is working towards a full resolution of this condition. If there are users who are not backing up for more than 48 hours, this would be unrelated to this incident, and a support ticket should be opened.
Posted Mar 03, 2023 - 13:23 MST
Update
The fix was released, and backups are proceeding. Early monitoring is showing that the fix is resolving the issue with affected backups. Due to the nature of how the fix works, it may take up to 72 hours for all affected backups to be shown as fully healthy. We are continuing to monitor very closely the situation.
Posted Mar 01, 2023 - 07:03 MST
Identified
The root cause of this issue is known and has been precisely identified. Certain mailboxes or onedrive/sharepoint sites with a certain rare document type are failing during full-text indexing. This is causing backups for these particular users to fail. A fix has been implemented, and is undergoing testing. The fix is estimated to be released early next week.
Posted Feb 24, 2023 - 13:50 MST
Investigating
Axcient x360Cloud is currently experiencing degraded backup services in North America and Europe. We are working on fully restoring the service. x360Cloud web application and restoration functions are not impacted by the issue.
Posted Feb 21, 2023 - 07:49 MST
This incident affected: x360Cloud (Microsoft 365 Backup (US), Google Workspace Backup (US), Microsoft 365 Backup (EU), Google Workspace Backup (EU)).