x360Portal Product Cards Disabled
Incident Report for Axcient
Resolved
We have determined the cause and resolved the issue as well taken steps to prevent this in the future.
Posted Mar 28, 2024 - 11:46 MDT
Investigating
We are investigating an issue with the x360Portal Dashboard where the Product Cards are not accessible. We are working to resolve this issue quickly. For users attempting to access their products, you can still login directly with your SSO account by visiting the products directly.
Posted Mar 28, 2024 - 10:37 MDT
This incident affected: x360Portal (Dashboard).