x360Recover Incident

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 12:21 MDT

Monitoring

System performance has stabilized and job processing is back to normal. We are continuing to monitor closely to ensure everything remains healthy.
Posted Jul 01, 2025 - 11:31 MDT

Investigating

We are experiencing an issue with x360Recover and we are currently investigating the root cause.
This issue affects this pieces of our functionality on storage nodes:
Seeding
Replication (GEO+)
Async export deletions
Azure blob uploads
Posted Jul 01, 2025 - 09:03 MDT
This incident affected: x360Recover (x360Recover Cloud (US), x360Recover Cloud (EU), x360Recover Cloud (CA)).