x360Cloud Issue

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 10:57 MST

Update

Remediations have been applied to resolve performance issues.
Posted Feb 26, 2025 - 10:54 MST

Update

We are continuing to work on a fix for this issue.
Posted Feb 26, 2025 - 09:02 MST

Identified

We have identified the root cause of the x360Cloud issue and are now expediting a solution.
Posted Feb 26, 2025 - 08:01 MST
This incident affected: x360Cloud (x360Cloud Management Portal (US)).