x360Cloud Canada Backup Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Jan 17, 2025 - 18:33 MST
Identified
We have identified the root cause of an issue impacting a small number of scans within various organizations in the Canada region beginning yesterday morning (Jan 16th). Backups are expected to complete successfully through today.
Posted Jan 17, 2025 - 10:49 MST
This incident affected: x360Cloud (Microsoft 365 Backup (CA), Google Workspace Backup (CA)).