x360Recover Virtual Office Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Jun 27, 2024 - 10:01 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2024 - 08:00 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 27, 2024 - 07:37 MDT
Investigating
We are investigating an issue with Axcient x360Recover Virtual Office. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Jun 27, 2024 - 05:57 MDT
This incident affected: Business Recovery Cloud (BRC) (BRC Cloud Virtual Office (US), BRC Cloud Virtual Office (CA)) and x360Recover Manager (x360Recover Virtual Office (US), x360Recover Virtual Office (CA), x360Recover Virtual Office (EU)).