The root causes of the recent backup slowdown have been remediated. Scans are trending toward normal levels, and we expect full performance and frequency to return within the next 24 hours. Monitoring is ongoing.
Posted Oct 03, 2025 - 14:41 MDT
Update
We continue to monitor the situation. Steady progress has been made, and performance is moving in the right direction as we work toward full stability.
Posted Oct 03, 2025 - 07:11 MDT
Monitoring
The root cause has been addressed and a fix has been implemented. We are now monitoring the environment to validate stability and ensure no further impact.
Posted Oct 02, 2025 - 15:09 MDT
Identified
Degraded performance on the US instance of X360Cloud is still under investigation. Mitigation measures have been applied and some improvements are visible, though service is not yet fully stable. Our team continues working to restore normal performance.
Posted Oct 02, 2025 - 08:07 MDT
Update
Degraded performance on the US instance of X360Cloud remains under investigation. We have identified contributing factors and are applying measures to stabilize performance.
Posted Oct 01, 2025 - 13:35 MDT
Update
We are continuing to investigate this issue.
Posted Oct 01, 2025 - 10:00 MDT
Investigating
Degraded performance has been identified for some organizations on the US instance of X360Cloud. Our team is actively working toward a resolution and will share updates as they become available.
Posted Oct 01, 2025 - 09:54 MDT
This incident affects: x360Cloud (Microsoft 365 Backup (US), Google Workspace Backup (US)).