x360Recover (formerly Replibit) Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted May 14, 2024 - 13:53 MDT
Monitoring
All partners vaults hosted in the x360Recover Cloud EU region have been restored
Posted May 14, 2024 - 13:24 MDT
Update
More than 70% of affected vaults have been restored to normal service, with additional vaults returning to normal service continuously. At the current rate, all affected vaults are expected to be restored to normal service within a few hours.
Posted May 14, 2024 - 10:04 MDT
Update
More than 70% of affected vaults have been restored to normal service, with additional vaults returning to normal service continuously. At the current rate, all affected vaults are expected to be restored to normal service within a few hours.
Posted May 14, 2024 - 10:04 MDT
Update
We are continuing to work on a fix for this issue.
Posted May 14, 2024 - 03:18 MDT
Update
We are continuing to work on a fix for this issue.
Posted May 14, 2024 - 02:45 MDT
Identified
We have identified the root cause of the x360Recover issue and are now expediting a solution.
Posted May 14, 2024 - 02:43 MDT
This incident affected: x360Recover (x360Recover Cloud (EU)).