x360Cloud US Backups
Incident Report for Axcient
Resolved
The issue with Axcient x360Cloud is resolved. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted May 14, 2024 - 11:41 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2024 - 04:08 MDT
Identified
We are investigating an issue affecting x360Cloud US backups
Posted May 11, 2024 - 02:55 MDT
This incident affected: x360Cloud (x360Cloud Management Portal (US), x360Cloud Smart Search (US), Microsoft 365 Backup (US), Microsoft 365 Restore (US), Google Workspace Backup (US), Google Workspace Restore (US), x360Cloud Management Portal (EU), x360Cloud Smart Search (EU), Microsoft 365 Backup (EU), Microsoft 365 Restore (EU), Google Workspace Backup (EU), Google Workspace Restore (EU)).