x360Recover Issue in US

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 06:16 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2025 - 14:48 MST

Update

We have restored services to most affected partners at this point. There are currently a small number of affected partners that we are working to fully restore service.
Posted Feb 01, 2025 - 07:52 MST

Identified

We are experiencing an issue with x360Recover backup and restores affecting a small number of partners since Jan 29th. The issue has been identified and we are working to re-enable services as quickly as possible.
Posted Jan 31, 2025 - 08:31 MST
This incident affected: x360Recover (x360Recover Cloud (US)).