x360Recover US Incident

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted 12 days ago. Apr 22, 2025 - 08:43 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 19 days ago. Apr 15, 2025 - 12:01 MDT

Identified

We are experiencing an issue with x360Recover backup and restores affecting a small number of partners. The issue has been identified and we are working to re-enable services as quickly as possible.
Posted 24 days ago. Apr 10, 2025 - 06:24 MDT
This incident affected: x360Recover (x360Recover Cloud (US)).