Multiple Product Incident for US Region

Incident Report for Axcient

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 17:35 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2025 - 15:55 MST

Identified

We are working on an issue affecting a portion of our infrastructure. Partners using x360Recover, BRC, or 3rd party BDR services may experience issues utilizing services while the incident is under investigation.
Posted Feb 04, 2025 - 15:19 MST
This incident affected: Axcient Cloud Services (BDR for ShadowProtect Next-gen Cloud Replication, BDR for ShadowProtect Cloud Backup (Legacy), BDR for Veeam, BDR for Quest), x360Recover (x360Recover Cloud (US)), x360Recover Manager (x360Recover Tunnel Services, BRC Cloud Tunnel Services, x360Recover Virtual Office (US)), and Business Recovery Cloud (BRC) (BRC Offsite Replication (US), BRC Cloud Virtual Office (US)).