x360Cloud (formerly CloudFinder) Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 01:23 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2022 - 06:19 MDT
Identified
We have identified an intermittent issue with x360Cloud web application in the US - x360Cloud web application sometimes is not accessible or users cannot log in there. We are working on a resolution. The issue blocks ability to initiate new restorations, but doesn't impact backups.
Posted Jun 23, 2022 - 04:25 MDT
This incident affected: x360Cloud (x360Cloud Management Portal (US)).