Monitoring has demonstrated that all services are fully operational. This incident is resolved.
Posted Sep 25, 2023 - 23:20 MDT
Monitoring
All services have been restored for all EU customers. We will continue monitoring to ensure they remain available.
Posted Sep 25, 2023 - 14:12 MDT
Update
Monitoring has shown that services have returned to normal, except service is still degraded for a small portion of the cloud for x360Recover.
Posted Sep 25, 2023 - 10:31 MDT
Update
The root cause of the issue was identified and resolved. Most services have returned to normal operations already. x360Recover vaults in this region will still take several hours before they return to normal service levels.
Posted Sep 24, 2023 - 22:30 MDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 24, 2023 - 12:46 MDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 24, 2023 - 10:58 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 24, 2023 - 10:11 MDT
Investigating
We are investigating an issue where multiple services are being affected. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Sep 24, 2023 - 10:10 MDT
This incident affected: x360Recover (x360Recover Cloud (EU)), Axcient Cloud Services (BDR for Quest), x360Sync (x360Sync Web (EU), x360Sync Data Transfer (EU), x360Sync Collaborative Web Editing (EU), x360Sync Web Preview (EU)), and x360Cloud (x360Cloud Management Portal (EU), x360Cloud Smart Search (EU), Microsoft 365 Backup (EU), Microsoft 365 Restore (EU), Google Workspace Backup (EU), Google Workspace Restore (EU)).