Axcient Cloudfinder EU SaaS Issues
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 19:57 MST
Identified
We have identified an issue in our EU data center interrupting most to all Cloudfinder components. We are working on a resolution.
Posted Feb 17, 2020 - 17:19 MST
This incident affected: x360Cloud (x360Cloud Management Portal (US), x360Cloud Smart Search (US), Microsoft 365 Backup (US), Microsoft 365 Restore (US)).