Axcient Anchor EU SaaS Issues
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Jan 29, 2020 - 15:15 MST
Investigating
We are investigating an issue with Axcient Anchor EU Web. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Jan 29, 2020 - 15:04 MST
This incident affected: x360Sync (x360Sync Web (EU)).