Anchor EU SaaS Issues
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Oct 24, 2019 - 18:57 MDT
Identified
We believe we have identified an issue causing syncedtool.eu to be inaccessible to many users, and are working on a resolution.
Posted Oct 24, 2019 - 18:29 MDT
This incident affected: Anchor (Europe) (Anchor Web, Anchor Sync, Anchor Email Notification, Anchor Collaborative Web Editing, Anchor Web Preview, Anchor Private Cloud Collaborative Web Editing, Anchor Private Cloud Web Preview).