x360Cloud (formerly CloudFinder) Issue
Incident Report for Axcient
Resolved
The incident has been resolved.
Posted Aug 12, 2022 - 03:57 MDT
Update
The issue has been resolved in the US. Fix for Google Workspace user synchronisation in x360Cloud EU is going to be applied within several hours.
Posted Aug 11, 2022 - 07:37 MDT
Update
We are continuing to work on a fix for the issue.
Posted Aug 10, 2022 - 05:25 MDT
Identified
Synchronisation of new Google Workspace user accounts and shared drives from Google Workspace to x360Cloud is sometimes failing. All accounts and drives that were created in Google Workspace before 5th of August are being backed up as expected. Restorations are not impacted. We are working on a resolution for the synchronisation issue.
Posted Aug 08, 2022 - 11:00 MDT
This incident affected: x360Cloud (Google Workspace Backup (US), Google Workspace Backup (EU)).