x360Sync (formerly Anchor) Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 18:23 MST
Investigating
We are investigating an issue with Axcient x360Sync (formerly Anchor). We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Nov 25, 2022 - 13:55 MST
This incident affected: x360Sync (x360Sync Web (CA), x360Sync Data Transfer (CA)).