x360Sync (formerly Anchor) Issue
Incident Report for Axcient
Resolved
The issue with x360Sync is resolved. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted Sep 15, 2022 - 09:55 MDT
Identified
We are working to improve performance
Posted Sep 13, 2022 - 11:59 MDT
This incident affected: x360Sync (x360Sync Web (CA)).