x360Cloud US SaaS Issues
Incident Report for Axcient
Resolved
The issue has been resolved and both portals are now accessible again.
Posted Apr 14, 2021 - 15:31 MDT
Identified
We're currently experiencing an outage which is resulting in the x360Cloud application being inaccessible. We're currently investigating the issue and hope to provide a resolution soon.
Posted Apr 14, 2021 - 15:23 MDT
This incident affected: x360Cloud (formerly CloudFinder) in North America (x360Cloud Management Portal, x360Cloud Smart Search, Microsoft 365 Restore, Google Workspace Restore).