Axcient Anchor US SaaS Issues
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 13:02 MST
Update
We are continuing to investigate this issue.
Posted Nov 22, 2019 - 12:29 MST
Investigating
We are investigating an issue with Axcient Anchor US SaaS. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Nov 22, 2019 - 11:59 MST
This incident affected: x360Sync (x360Sync Web (US), x360Sync Collaborative Web Editing (US), x360Sync Web Preview (US)).