x360Recover (formerly Replibit) Issue
Incident Report for Axcient
Resolved
The issue with Axcient x360Recover is resolved. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted Jan 19, 2023 - 16:59 MST
Monitoring
We implemented a solution to resolve the issue with x360Recover. We are now monitoring the results.
Posted Jan 19, 2023 - 15:30 MST
Identified
We have identified the root cause of the x360Recover issue and are now expediting a solution.
Posted Jan 19, 2023 - 12:24 MST
Investigating
We are investigating an issue with Axcient x360Recover (formerly Replibit) where a small number of vaults are offline. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Jan 19, 2023 - 07:37 MST
This incident affected: x360Recover (x360Recover Cloud (US)).