x360Cloud (formerly CloudFinder) Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 10:37 MDT
Monitoring
We implemented a solution to resolve the issue with x360Cloud, backups are fully operational now. Now we are monitoring and backup reports stabilisation as a result.
Posted Jun 21, 2022 - 02:34 MDT
Update
We are continuing to investigate this issue.
Posted Jun 20, 2022 - 07:40 MDT
Investigating
We have identified and are investigating an issue with x360Cloud backups performance in the USA. We are working on a resolution.

The web application remains online, search and restoration features are fully functional.
We'll update this status page with more information as we learn more.
Posted Jun 20, 2022 - 07:40 MDT
This incident affected: x360Cloud (Google Workspace Backup (US), Microsoft 365 Backup (EU)).