x360Recover (formerly Replibit) Issue
Incident Report for Axcient
Resolved
The issue with Axcient x360Recover is resolved. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted Jun 14, 2021 - 09:54 MDT
Investigating
We are investigating an issue with Axcient x360Recover (formerly Replibit). We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Jun 14, 2021 - 09:04 MDT
This incident affected: x360Recover (x360Recover Cloud (US), x360Recover Cloud (EU), x360Recover Cloud (CA), Authentication Token Service, Cloud Key Management System, License Portal, Partition API, Salesforce Ticket Gateway).