x360Sync client having troubles with connecting to service in EU
Incident Report for Axcient
Resolved
The issue is resolved.
We have identified higher resources consumption with one of the latest releases.
To avoid our users to experience slowness, we have rolled out the previous version.
We are closely monitoring the system performance and do not expect any new issues.
Sorry for any inconvenience. (edited)
Posted Dec 02, 2020 - 08:17 MST
Investigating
We are currently investigating this issue.
Posted Dec 02, 2020 - 07:30 MST
This incident affected: x360Sync (x360Sync Data Transfer (EU)).