x360Recover (formerly Replibit) Issue
Incident Report for Axcient
Resolved
The issue with Axcient x360Recover is resolved. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted May 16, 2022 - 18:36 MDT
Update
We are seeing performance at normal levels, but we are continuing to monitor the situation.
Posted May 16, 2022 - 11:45 MDT
Update
We are continuing to monitor the situation and are seeing an overall improvement in backup performance.
Posted May 11, 2022 - 11:33 MDT
Monitoring
We implemented a solution to resolve the issue with x360Recover. We are now monitoring the results.
Posted May 10, 2022 - 07:52 MDT
Identified
We have identified an issue with Axcient x360Recover (formerly Replibit). A small portion of backups are completing slower than expected.

We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted May 06, 2022 - 10:22 MDT
This incident affected: x360Recover (x360Recover (formerly Replibit) Cloud (US)).