x360Recover (formerly Replibit) Issue
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 15:17 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2021 - 12:44 MDT
Investigating
We are investigating an issue with Axcient x360Recover (formerly Replibit). We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted Sep 28, 2021 - 12:06 MDT
This incident affected: x360Recover (x360Recover Cloud (US)).