Axcient x360Cloud US SaaS Issues
Incident Report for Axcient
Resolved
We confirmed the issue remains resolved. We will perform a post-mortem analysis with key stakeholders to identify preventive measures that may be implemented in the future. We apologize for any inconvenience this may have caused you and thank you for your patience and support throughout this process.
Posted Apr 14, 2021 - 18:55 MDT
Update
We've implemented a fix and are monitoring the situation. All services are currently available again.
Posted Apr 14, 2021 - 17:27 MDT
Monitoring
We're continuing to see some issues with connectivity to the x360Cloud SaaS applications. We will continue to monitor the situation and provide an update shortly.
Posted Apr 14, 2021 - 15:47 MDT
This incident affected: x360Sync (formerly Anchor) in United States (x360Sync Web, x360Sync Data Sync, x360Sync Collaborative Web Editing, x360Sync Web Preview, x360Sync Private Cloud Collaborative Web Editing, x360Sync Private Cloud Web Preview) and x360Cloud (formerly CloudFinder) in North America (x360Cloud Management Portal, x360Cloud Smart Search, Microsoft 365 Restore, Google Workspace Restore).