BRC Offsite Storage
Incident Report for Axcient
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 12:48 MST
Investigating
We are investigating this issue.
Posted Nov 23, 2020 - 07:51 MST
This incident affected: Business Recovery Cloud (BRC) (BRC Offsite Replication (US), BRC Offsite Replication (CA)).