BRC (Business Recovery Cloud) Issue
Incident Report for Axcient
Resolved
This incident is now resolved.
Posted May 17, 2021 - 16:12 MDT
Monitoring
We have fixed the issue with BRC and are now monitoring the results.
Posted May 17, 2021 - 13:28 MDT
Identified
We have identified the root cause of the BRC issue and are now expediting a solution.
Posted May 17, 2021 - 12:55 MDT
Investigating
We are investigating an issue with Axcient BRC. We apologize for any inconvenience this may cause you. We'll update this status page with more information as we learn more.
Posted May 17, 2021 - 08:38 MDT
This incident affected: Business Recovery Cloud (BRC) (BRC Offsite Replication (US)).